We are pleased to confirm full vessel connectivity is is restored as previously reported and all processing backlogs have cleared This incident is now closed
Posted Jul 16, 2026 - 12:47 UTC
Monitoring
Further on this matter Pleased to advise we have implemented a fix and vessel connections have now resumed. A small backlog has built up during the incident whe our system is currently processing.
We continue to monitor the situation carefully
Posted Jul 16, 2026 - 12:16 UTC
Investigating
We are currently investigating an issue affecting GTMailPlus, which is causing delays in mail processing and intermittent connection difficulties for vessels.
Mail continues to queue safely and no messages are being lost
We are treating this as a high priority and will provide further updates as soon as more information becomes available.
We apologise for the disruption and appreciate your continued patience.
Posted Jul 16, 2026 - 11:32 UTC
This incident affected: GTMailPlus (Ship to Shore Delivery, Shore to Ship Delivery, IP Communications).